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Abstrakt: Monitorování vnitřní struktury nanovlákenných vrstev je složitý proces, jehož cílem je přesné 

stanovení kvantitativních nebo kvalitativních prametrů objektů zájmu, za které považujeme vlákna, mezivlákenné 

póry nebo celé vlákenné systémy. Metody stanovení parametrů nanovláken vychází především z nástrojů 

obrazové analýzy, jejímž výstupem jsou obrazová data popisující vlastnosti definovaných objektů. Příspěvek 

se zabývá představením navržených objektivních algoritmů v prostředí programu MATLAB a popisem 

posloupných kroků v programu ImageJ vedoucích k určení základních chrarakteristik nanovlákenných vrstev, 

jakými je průměr vláken, parametry mezivlákenných póru, vlastnosti vyskytujících se defektů a orientace 

vlákenných systémů.   

Klíčová slova: Nanovlákna, póry, průměr vláken, detekce defektů, orientace, obrazová analýza, algoritmus 

navržený pro MATLAB, posloupnost kroků v ImageJ.  

 

Úvod 
Nanovlákna jsou vlákna v rozsahu desítek až stovek nanometrů, jejich zanedbatelná struktura 

je nositelem unikátních vlastností, které jsou určující pro aplikace, ve kterých jsou obsaženy. 

Vzhledem ke svým vlastnostem jsou nanovlákna úspěšně aplikována v různých průmyslových 

oborech jako je například automobilový průmysl, zdravotnictví, tkáňové inženýrství, stavební 

průmysl a další.  Pro maximální využití vlastností nanovláken mezi které patří velký měrný 

povrch, vysoká porózita, zanedbatelný průměr a velikost pórů, je nutné dokonale identifikovat 

jejich strukturní parametry. Starší metody stanovení parametrů nanovláken jsou založeny 

především na manuálních metodikách měření realizovaných pomocí primitivních nástrojů 

obrazové analýzy, mezi které patří například digitální pravítko. Tyto metody jsou nefektivní, 

subjektivní, špatně interpretovatelné a nepřesné.  

V tomto příspěvku jsou uvedeny automatizované metody identifikace základních parametrů 

nanovlákenných vrstev navržené v rámci řešení diplomové práce ve dvou programových 

prostředích umožňujících obrazovou analýzu. Mezi parametry nanovláken pro které byly 

stanoveny v rámci řešení diplomové práce algoritmy usnadňující jejich detekci patří 

 stanovení základních charakteristik mezivlákenných pórů, 

 detekce a určení parametrů defektů vyskytujících se v nanovlákenných vrstvách, 

 stanovení orientyce nanovláken, 

 určení průměru nanovláken.  

 Prvním programem ve kterém byly navrženy objektivní algoritmy pro stanovení parametrů 

nanovlákenných struktur je interaktivní program MATLAB, druhým programem ve kterém 

byla navržena posloupnost kroků identifikace parametrů nanovlákenných strukturje volně 

dostupný a uživatelsky atraktivní program ImageJ. V obou programových prostředích byly 

parametry nanovlákenných vrstev stanoveny na základě SEM snímků polykaprolaktanových 

nanovlákenných vrstev vytvořených v laboratoři KNT elektrostatickým zvlákňováním. 

Jednotlivé vytvořené nanovlákenné vrstvy se lišily koncentrací zvlákněného polymeru, na 

snímcích určených k testování metodik stanovení základních parametrů byly například 
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zobrazeny vrstvy zvlákněného PCL o koncentracích 14%, 16%, 18% a 20% zobrazené na obr. 

1(a)-(d). 

    
(a) (b) (c) (d) 

Obr. 1 Monochromatický snímek 14% PCL (a), 16% PCL (b), 18% PCL (c), 20% PCL (d).  

1. Určení parametrů pórů nanovlákenných vrstev 

Porózita je vlastnost nanovlákenných vrstev, která ovlivňuje prodyšnost a prostupnost jiných 

medií materiálem.V následujících podkapitolách jsou uvedeny metody stanovení parametrů 

mezivlákenných pórů v prostředí programu MATLAB a prostředí programu ImageJ. 

 

1.1 Metodika navržená ke stanovení parametrů pórů v programu MATLAB 

V prostředí programu MATLAB bylo stanovení parametrů nanovlákenných pórů realizováno 

na základě navrženého algoritmu, jehož princip vychází ze segmentace obrazu.  Metoda je 

demonstrována na monochromatickém snímku 14% PCL uvedeném na obr. 2 (a), 

po odstranění šumu následuje binarizace obrazu pomocí prahování a sada morfologických 

operací (například vyplnění děr objektů). Binární obraz je uveden na obr. 2(b). Dalším krokem 

je převod binárního obrazu na negativ (obr. 2(c)) a potlačení nekompletních objektů ležících 

na obrazové hranici. Takto upravený obraz uvedený na obr. 2 (d) slouží jako vstup 

pro vyhodnocení základních parametrů pomocí dostupné zaimplementované funkce. 

Posloupnost jednotlivých kroků tvořících algoritmus spolu s uvedenými zaimplementovanými 

funkcemi programu MATLAB jsou uvedeny níže. 

 Odstraň šum vstupního obrazu použitím mediánového filtru (medfilt2.m). 

 Převeď vstupní obraz na binární, použij operaci prahování, hodnotu prahu T nalezni 

experimentálně (im2bw.m). 

 Odstraň malé objekty z obrazu (bwareaopen.m). 

 Potlač nekompletní struktury dotýkající se hranic obrazu (imclearborder.m). 

 Převeď pixely nesoucí informaci 1 na 0 a naopak, (vytvoř negativ obrazu). 

 Detekuj jednotlivé regiony, vytvoř vstupní matici pro získání informací 

o objektech(bwlabel.m).  

 Detekuj hranice pórů, vykresli je do vstupního obrazu (imerode.m).   

 Proveď kalibraci, převeď pixely jednotlivých regionů na mikrometry. 

 Vypočítej parametry jednotlivých regionů, vyhodnoť parametry pórů celého obrazu 

(regionprops.m). 

Na základě uvedeného algoritmu byly prostřednictvím navržené metody stanoveny 

v prostředí programu MATLAB parametry mezivlákenných pórů nanovlákenných vrstev 

lišících se koncentrací PCL uvedené v tab. 1. 
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(a) (b) (c) (d) 

Obr. 2 Vstupní monochromatický snímek nanovlákenné vrstvy 14% PCL (a), transformovaný binární snímek (b), 

negativní obraz po sérii morfologických operací (c), obraz s potlačenými nekompletními objekty (d). 

Tab. 1 Výsledky stanovení základních parametrů pórů nanovlákenných vrstev lišících se koncentrací v Matlabu. 

Koncentrace  Počet 

pórů 

Celková 

plocha [µm
2
] 

Průměrná 

plocha [µm
2
] 

Std 

[µm
2
] 

Porózita 

[%] 

Průměrný 

obvod [µm] 

Std 

[µm] 

14 PCL [%] 266 180.78 0.67 1.09 45 3.25 3.13 

16 PCL [%] 248 238.88 0.96 1.58 59 3.99 3.85 

18 PCL [%] 116 160.07 1.37 2.79 40 4.95 5.55 

20 PCL [%] 124 31757 256.11 331.79 35 85.11 84.98 

 

1.1 Metodika navržená ke stanovení parametrů pórů v programu ImageJ 

V prostředí programu ImageJ byl aplikován stejný princip stanovení základních parametrů 

mezivlákenných pórů jako tomu bylo v prostředí programu MATLAB. Navržené kroky 

vedoucí ke stanovení základních parametrů pórů jsou uvedeny v tab. 2. 

Tab. 2 Kroky navržené v programu ImageJ vedoucí k zjištění základních charakteristik pórů.  

Analyze → Set Scale  Proveď kalibraci pixelů na reálné jednotky 

Image → Crop  Vyřež vstupní obraz 

Process → Noise → Despeckle   Odstraň šum mediánovým filtrem 

Image → Adjust → Treshold  Transformuj vstupní obraz na binární prahováním 

Process → Binary →Fill Holes  Vyplň díry morfologickou operací 

Analyze → Set Measurements  Nastav parametry určené k vyhodnocení 

Analyze → Analyze Particles  Analyzuj jednotlivé objekty 

Results → Distribution  Zobraz distribuci naměřených parametrů 

Analyze → Summarize  Stanov výsledky měření použitím statistických operací 

 

Na obr. 2(a) je uveden vstupní snímek 14% PCL po odstranění šumu, na obr. 2 (b) je zobrazen 

binarizovaný snímek po aplikaci série morfologických operací. Na obr. 2(c) je zobrazeno 

dialogové okno Analyze Particles sloužící v prostředí ptogramu ImageJ jako nástroj pro 

určení parametů pórů a na obr. 2(d) jsou pomocí indexů označeny póry, které byly 

vyhodnoceny. Stejně jako v MATLABU nebyly vyhodnoceny nekompletní objekty ležící na 

hranici obrazu. V tab. 3 jsou uvedeny výsledky stanovení parametrů pórů v programu Imagej. 
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(a) (b) (c) (d) 

Obr. 2 Vstupní monochromatický snímek nanovlákenné vrstvy 14% PCL (a), transformovaný binární snímek po 

sérii morfologických operací (b), dialogové okno Analyze Particles(c), indexy označené póry jejichž parametry 

byly vyhodnoceny(d). 

Tab. 3 Výsledky stanovení základních parametrů pórů nanovlákenných vrstev lišících se koncentrací v ImageJ. 

Koncentrace  Počet 

pórů 

Celková plocha  

[µm
2
] 

Průměrná plocha 

[µm
2
] 

Std 

[µm
2
] 

Porózita 

[%] 

Obvod 

[µm] 

Std 

[µm] 

14 PCL [%] 253 175.60 0.69 1.10 45 3.35 3.08 

16 PCL [%] 238 237.23 1.00 1.61 60 4.10 3.81 

18 PCL [%] 110 159.01 1.45 2.84 40 5.18 5.53 

20 PCL [%] 117 31008.18 265.03 325.24 35 89.06 82.74 
 

Navržené metodiky stanovení parametrů pórů v prostředí programu MATLAB i prostředí 

programu ImageJ lze považovat za přesné, vzhledem ke shodě dosažených výsledků.  

2. Určení parametrů kulovitých defektů nanovlákenných vrstev 

Na pořízených snímcích PCL nanovlákenných vrstev zobrazených na obr. 1(a)-(c), jsou 

viditelné nežádoucí kulovité útvary - defekty, způsobené nízkou koncentrací PCL 

ve zvlákňovaném roztoku. Parametry těchto defektů byly v prostředí programu MATLAB  

a v prostředí programu ImageJ zjišťovány dvěma rozdílnými způsoby. Uvedené metody jsou 

pro demonstraci realizovány na snímku nanovlákenné vrstvy 14% PCL uvedené na obr. 1(a). 

První způsob vyhledává defekty za použití korelační metody. Druhý způsob je založen na 

segmentaci defektů z obrazu. 

 

2.1 Metodika stanovení parametrů defektů korelační metodou v programu MATLAB 

Princip metody vychází z práce autorů Gonzalese a Woodse [1] a je založen na vzájemné 

korelaci upraveného binárního obrazu 14 % PCL zobrazeného na obr. 3(a) a vytvořené 

šablony uvedené na obr. 3(b) definující tvar hledaných objektů ve všech místech obrazu. 

Výstupem metody je korelovaný obraz zobrazený na obr. 3(c), místa, ve kterých byl 

detekován hledaný objekt jsou místa s nejvyšší vzájemnou korelací a jsou reprezentována 

nejsvětleji, na obr. 3(b) je místo nejvyšší shody označeno červeným rámečkem. Parametry 

defektů jsou určeny z binarizovaného korelovaného obrazu uvedeného na obr. 3(d). Navržený 

algoritmus pro stanovení parametrů defektů v prostředí programu MATLAB je uveden níže.  

 Převeď vstupní obraz na binární, použij operaci prahování, hodnotu prahu nalezni 

experimentálně jako interval, ten odvoď od hodnot úrovně šedi defektů (imtool.m). 

 Uprav obraz použitím morfologických operací, odstraň malé objekty, vyplň díry 

v objektech, potlač objekty ležící na hranici obrazu. (bwareaopen.m, 

imclearborder.m, imfill.m). 

 Vytvoř vzorovou šablonu pro detekci defektů (strel.m, padarray.m). 
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  Použitím filtru rozostři obraz (imfilter.m, fspecial.m, unsharp.m). 

 Proveď korelaci mezi šablonou a obrazem, najdi a vyznač místo s nejvyšší korelací 

(dftcorr.m). 

 Proveď prahování korelovaného obrazu (im2bw.m). 

 Vytvoř vstupní matici pro získání informací o jednotlivých regionech (bwlabel.m). 

 Proveď kalibraci, převeď pixely jednotlivých defektů na mikrometry. 

 Vypočítej a vyhodnoť parametry jednotlivých defektů (regionprops.m). 

 Vykresli obvody nalezených defektů do vstupního obrazu (bwmorph.m,  

remove.m). 

Výsledky detekce a stanovení parametrů defektů nanovlákenných vrstev jsou uvedeny v tab. 4. 

V nanovlákenné vrstvě 20% PCL nebyly nalezeny žáné defekty. Bylo zjištěno, že se zvyšující 

se koncentrací klesá výskyt defektů ve všech zkoumaných PCL nanovlákenných vrstvách. 

 

 

  

(a) (b) (c) (d) 

Obr. 3 Upravení binární obraz14% PCL (a), vyhledávací šablona (b), korelovaný obraz (c), výsledný obraz (d). 

Tab. 4 Základní parametry defektů nanovlákenných vrstev v závislosti na koncentraci určené v MATLABU. 

Koncentrace  n Celková plocha  

[µm
2
] 

Průměrná 

plocha [µm
2
] 

Std 

[µm
2
] 

Celkový 

obvod [µm] 

Průměrný 

obvod [µm] 

Std 

[µm] 

14 PCL [%] 24 3337.70 139.07 103.14 1016.40 42.35 21.40 

16 PCL [%] 13 12080.40 929.51 423.65 1396.20 107.40 28.17 

18 PCL [%] 5 1315.90 263.18 281.64 252.88 50.57 39.39 

 

2.2 Metodika stanovení parametrů defektů korelační metodou v programu ImageJ 

Stanovení defektů korelační metodou v prostředí programu ImageJ bylo realizováno 

prostřednictvím volně stahovatelného pluginu Create Template. Posloupnost kroků 

navržených pro určení parametrů defektů v prostředí programu ImageJ je uvedena v tab. 5. 

Výsledky stanovení parametrů defektů jsou uvedeny v tab. 6. V případě nanovlákenné vrstvy 

o koncentraci 20% PCL nebyly opět nalezeny žádné defekty.  

Tab. 5 Posloupnost kroků stanovení základních parametrů defektů korelační metodou v programu ImageJ. 

Analyze → Set Scale  Proveď kalibraci  pixelů na reálné jednotky 

Image → Crop  Vyřež  vstupní obraz na požadovanou velikost 

Image → Adjust → Treshold  Transformuj vstupní obraz na binární prahováním 

Process → Binary → Fill Holes Vyplň díry morfologickou operací 

Plugins → Create Template  Vytvoř šablonu 

Proveď korelaci mezi vstupním obrazem a šablonou 

Proveď prahování korelované obrazu a vyhodnoť 

výsledky 
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Tab. 6 Základní parametry defektů nanovlákenných vrstev v závislosti na koncentraci určené v ImageJ.  

Koncentrace  n Celková plocha  

[µm
2
] 

Průměrná 

plocha [µm
2
] 

Std 

[µm
2
] 

Obvod 

[µm] 

Std 

[µm] 

14 PCL [%] 37 3558.13 96.17 27.60 38.93 6.30 

16 PCL [%] 16 6642.00 415.18 118.02 78.57 9.92 

18 PCL [%] 3 348.86 87.21 57.15 39.75 12.31 

 

2.3 Metodika stanovení parametrů defektů segmentací v programu MATLAB a ImageJ 

Dalším metodou stanovení parametrů defektů vyskytujících se v nanovlákenných vrstvách 

vláken je přístup založený na segmentaci obrazu. Metoda je totožná s metodou určení 

základních parametrů pórů s tím rozdílem, že jsou jako objekty zájmu vnímány defekty 

a tranformace na binární obraz je realizována prostřednictvím použití prahové hodnoty, která 

je definovaná jako interval ohraničený minimální a maximální hodnotou šedi kulovitých 

defektů vyskytujících se v nanovlákenných vrstvách. Výsledky stanovení parametrů defektů 

založené na segmentaci získané v prostředí programu MATLAB jsou uvedeny v tab. 7, 

výsledky stanovení parametrů defektů zjištěné v programu ImageJ jsou uvedeny v tab. 8. V 

obou případech nebyly ve vrstvě 20% PCL nalezeny žádné defekty. 

 
Tab. 7 Základní parametry defektů nanovlákenných vrstev v závislosti na koncentraci určené v MATLABU. 

Koncentrace n Celková plocha  

[µm
2
] 

Průměrná 

plocha [µm
2
] 

Std 

[µm
2
] 

Celkový 

obvod [µm] 

Průměrný 

obvod [µm] 

Std 

[µm] 

14 PCL [%] 33 2868.20 86.91 38.37 1600.7 48.51 9.89 

16 PCL [%] 20 1201.20 600.61 306.39 2687.6 134.38 43.67 

18 PCL [%] 7 1504.50 214.93 168.60 751.42 107.35 39.27 

 
Tab. 8 Základní parametry defektů nanovlákenných vrstev v závislosti na koncentraci určené v ImageJ. 

Koncentrace n Celková plocha  

[µm
2
] 

Průměrná plocha [µm
2
] Std 

[µm
2
] 

Obvod 

[µm] 

Std 

[µm] 

14 PCL [%] 34 2755.28 81.04 40.03 36.95 9.26 

16 PCL [%] 21 12471.63 593.89 331.73 105.5 41.85 

18 PCL [%] 9 1669.56 185.51 180.30 69.74 37.76 

 

Stanovení parametrů defektů vyskytujících se v nanovlákenných vrstvách je komplikovaný 

proces. V rámci řešení diplomové práce se osvědčily metody vycházející ze segmentace 

obrazu, vzhledem k tomu, že v obou programech bylo dosaženo podobných výsledků 

shodujících se s reálnými rozměry a počtem defektů. Stanovení parametrů defektů založené na 

vzájemné korelaci obrazu a vyhledávací šablony, se jeví jako nevhodné z důvodu velkých 

rozdílů zjištěných výsledků v jednotlivých programových prostředích. 

3. Určení orientace nanovláken ve vlákenné vrstvě  

Orientace vláken je velmi důležitým parametrem, který ovlivňuje výsledné vlastnosti 

výchozích struktur, například kompozitních materiálů. Na orientaci vláken závisí především 

mechanické vlastnosti, tzn., pokud jsou vlákna plošné či délkové textilie orientovaná v jenom 

směru, textilie vykazuje v tomto směru vyšší pevnost.  Dále orientace vláken ovlivňuje 

prodyšnost, propustnost a absorpci kapalin vlákenných porézních materiálů.   

V práci Rataje a Saxla [2] je uvedena grafická metoda pro odhad anizotropie vláken, 

grafická metoda je experimentální a špatně interpretovatelný proces. Z tohoto důvodu 

je vhodné manuální grafickou metodu nahradit technikou založenou na obrazové analýze.  
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Podstata aplikovaných metodik určených ke stanovení orientace vláken vlákenné 

struktury vychází dle [3] z vlastností Fourierova spektra. Monochromatický snímek vlákenné 

vrstvy je nejprve Fourierovou transformací převeden do frekvenční oblasti, směr vláken je 

určen na základě výskytu  vysokých hodnot frekvenční oblasti. Pokud se jedná o náhodně 

orientovanou strukturu, obraz ve frekvenční oblasti má kruhovitý tvar. Všechny uvedené 

metodiky stanovení orientace vláken jsou pro demonstraci aplikovány na snímku 18% PCL 

nanovlákenné vrstvy zobrazeném dříve na obr. 1(c).  

 

3.1 Metodika stanovení orientace vláken v programu MATLAB  

Pro přesné určení směru nanovláken bylo nutné rozdělit vstupní obraz 18% PCL 

uvedený na obr. 1(a) na mnoho podobrazů, pro každý podobraz byla na základě Fourierovy 

transformace stanovena orientace vláken. Převládající orientace vláken v jednotlivých 

podoknech je na obr. 4(a) graficky znázorněna pomocí směrových vektorů, na obr. 4(b) jsou 

uvedeny směrové vektory ve stupním obraze. Výsledky stanovení orientace jendotlivých 

snímků byly interpretovány prostřednictvím polárního diagramu obr. 4(c), histogramu 

a jádrovému odhadu distrubuce směrů obr. 4(d).  Algoritmus navržený pro stanovení orientace 

vláken spolu s funkcemi aplikovanými v prostředí programu MATLAB je uveden 

v následujícím textu. 

 

 Uprav kontrast vstupního snímku (imadjust.m). 

- Definuj velikost okna ohraničující oblasti, pro které má být určena orientace. 

 Pro jednotlivé podobrazy proveď  2D Fourierovu transformaci (fft2.m).  

 Přiřaď počátek oblasti frekvenčních polí do středu podobrazu (fftshift.m).   

 Zredukuj dynamický rozsah koeficientů logaritmickou transformací. 

 Najdi hlavní a vedlejší osu elipsy definující tvar frekvenční oblasti. 

 Definuj nejnižší přijatelný poměr hlavní a vedlejší osy elipsy (regionprops.m). 

 Přiřaď směrový vektor jednotlivým frekvenčním oblastem. 

 Vytvoř histogram distribuce směrů vláken a proveď jádrový odhad hustoty.  

 Vytvoř polární diagram orientace vláken. 
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Obr. 4 Směrové vektory určené pro jednotlivé podobrazy vstupního snímku (a), směrové vektory zobrazené ve 

vstupním obraze (b), histogram a jádrový odhad hustoty distribuce směrů (c), polární diagram orientace (d). 

3.2 Metodika stanovení orientace vláken v programu ImageJ 

Stanovení orientace vláken v prostředí programu ImageJ vycházelo z aplikace dvou 

volně dostupných pluginů, v obou případech realizovaných  v prostředí programu ImajeJ byla 

orientace vláken stanovena na základě analýzy Fourierova frekvenčního spektra. Program 

ImageJ má otevřenou architekturu, kterou je možné rozšiřovat pomocí volně dostupných 

pluginů. Prvním aplikovaným pluginem byl plugin OrientationJ, který poskytuje uživateli 

možnost plně automatizovaného stanovení orientace vláken v nanovlákenné vrstvě 
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prostřednictvím nástroje Distribution. Výstupem nástroje Distribution je graf popisující 

četnost výskytu vláken nanovlákenné vrstvy 18% PCL o zjištěných orientacích uvedený na 

obr. 5(a) a RGB mapa směrů zobrazená na vstupním snímku uvedená na obr. 5(b). 

Posloupnost kroků zjištění orientace vláken prostřednictvím pluginu OrientationJ je uvedena 

v tab. 9. 

 
Tab. 9 Posloupnost kroků zjištění orientace vláken v programu ImageJ použitím pluginu OrientationJ. 

Image → Crop  Vyřež vstupní obraz 

Plugins → OrientationJ → Distribution  Automatizované stanovení orientace vláken 

 

Druhým aplikovaným pluginem vedoucím k zjištění orientace nanovláken ve vrstvě 

byl plugin Directionality, jenž je součástí volně dostupného balíčku Fiji rozšiřujícího funkce 

programu ImageJ. Tento plugin nabízí uživateli velmi snadné a intuitivně ovladatelné rozhraní 

umožňující rychlou a efektivní metodu stanovení orientace vláken v nanovlákenné vrstvě. 

Posloupnost kroků je uvedena v tab. 10. Výstupem je histogram orientace a mapa směrů 

vláken. Na obr. 5(c) je uveden histogram orientace vláken nanovlákenné vrstvy 18% PCL, 

na obr. 5(d) je uvedena odpovídající mapa směrů.   

 
Tab. 10 Posloupnost kroků zjištění orientace vláken v programu ImageJ použitím pluginu Directionality. 

Image → Crop  Vyřež vstupní obraz 

Analyze → Directionality  Automatizované stanovení orientace vláken 

 

 

 

 

 
(a) (b) (c) (d) 

Obr. 5 Graf popisující četnost orientace vláken snímku 18% PCL na základě pluginu OrientationJ (a), 

odpovídající mapa směrů (b), histogram orientace vláken zjištěná pluginem Directionality (c), odpovídající 

mapa směrů (d). 

 

V prostředí programu MATLAB je stanovení orientace vláken podmíněno tvorbou složitého 

algoritmu, což je možné považovat za uživatelsky nevýhodné. Prostředí programu ImageJ  je 

ujištění orientace vláken uživatelsky přístupnější a to především díky volně dostupným 

pluginům. 

4. Určení průměrů nanovláken ve vlákenné vrstvě  

Průměr vláken je jedním ze základních strukturních parametrů, od kterého se odvíjí vlastnosti 

celé vlákenné struktury. Často používanou metodou určenou k získání informací o průměrech 

vláken ze snímků vlákenných vrstev je manuální metoda, při níž je uživatel nucen naměřit 

a zaznamenat velké množství průměrů.Tato metodika je zdlouhavá, málo efektivní, obtížně 

reprodukovatelné a vzhledem k subjektivitě hodnocení nepřesná. Z tohotu důvodu bylo dalším 

cílem práce nalézt automatizovanou metodu stanovení průměrů vláken, která by byla efektivní 

a dobře reprodukovatelná.  



SVOČ 2013                                                                                                                     28. května 2013, Liberec 

Metoda, která byla pro stanovení automatického průměrů v obou programových prostředích 

v rámci řešení diplomové práce navržena, byla inspirována studií autorů Pourdeyhimi 

a Dent [4] a vychází ze stanovení Euklidovských vzdáleností pro objektové pixely, 

tzn. vzdáleností jednotlivých obrazových pixelů (pixelů vláken) od jejich nejbližšího pixelu 

reprezentujícího pozadí tzv. hranového pixelu.  

 

4.1 Metodika stanovení průměrů vláken v programu MATLAB 

Stanovení orientace vláken vstupního snímku 14% PCL zobrazeného na obr. 6(a), 

převedeného na binární obraz uvedený na obr. 6(b),  bylo provedeno na základě stanovení 

Euklidovských vzdáleností obrazových pixelů z transformovaného binárního obrazu na 

negativní, který je uveden na obr. 6(c). Mapa získaných Euklidovských vzdáleností je uvedena 

na obr. 6(d). Nejsvětlejší místa vzdálenostní mapy jsou hledané poloměry vláken. V prostředí 

programu MATLAB byl pro stanovení orientace vláken navržen následující algoritmus s 

přiřazenými zaimplementovanými funkcemi, které toto prostředí nabízí. Výsledky stanovení 

průměrů vláken jsou uvedeny v tab. 12. 

 Převeď vstupní binární obraz na negativ.  

 Vypočti Euklidovskou vzdálenost mezi všemi nulovým a jejich nejbližšími 

nenulovými pixely, vzdálenosti zapiš jako matici (bwdist.m). 

 Proveď skeletonizaci obrazu ztenčením, tím vyčleň poloměry vláken (bwmorph.m). 

 Detekuj průsečíky skeletonizované struktury. 

 Každému průsečíku vykresli kružnici o poloměru rovném průměru daného vlákna 

(imcircle.m). 

 Proveď kalibraci a vyjádři průměry vláken. 

 Sestroj histogram průměrů vláken. 

  

 

 

(a) (b) (c) (d) 

Obr. 6 Vstupní monochromatický snímek nanovlákenné vrstvy 14% PCL (a), binární obraz (b), negativ (c), 

získaná mapa Euklidovských vzdáleností (d).  

 

4.2 Metodika stanovení průměrů vláken v programu ImageJ 

Algoritmus uvedený v prostředí programu MATLAB byl použitím odpovídajících nástrojů 

aplikován v prostředí programu ImageJ. Princip zjištění průměru nanovláken je založen 

na průniku kostry vláken a mapy Euklidovských vzdáleností, čímž jsou ponechány pouze 

poloměry vláken. Posloupnost kroků navržených v prostředí programu ImageJ vedoucí 

ke stanovení průměru vláken je uvedena v tab. 11. Výsledky stanovení průměrů vláken jsou 

uvedeny v tab. 12.  

 
Tab. 11 Posloupnost kroků zjištění průměrů vláken v programu ImageJ. 

Process → Filters → Median  Odstraň šum mediánovým filtrem 

Image → Adjust → Treshold  Transformuj vstupní obraz na binární  
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Image → Duplicate  Vytvoř kopii binárního obrazu 

Process → Binary → Distance Map  Vytvoř mapu Euklidovských vzdáleností vláken 

Process → Binary → Skeletonize  Vytvoř skeleton (kostru) vláken 

Process → Image Calculator → AND  Získej poloměry vláken prostřednictvím průniku 

dvou obrazů 

Process → Math → Multiple  Vynásob obraz konstantou, získej průměr vláken  

Analyze → Histogram Interpretuj výsledky měření histogramem 

 
Tab. 12 Výsledky stanovení průměrů vláken v závislosti na koncentraci PCL v obou programech. 

 Výsledky dosažené v MATLABU Výsledky dosažené v ImageJ 

Koncentrace Průměr [μm] Std [μm] Průměr [μm] Std [μm] 

14% PCL 0.16 0.09 0.16 0.09 
16% PCL 0.22 0.15 0.21 0.13 
18% PCL 0.19 0.22 0.17 0.14 
20% PCL 0.65 0.70 0.56 0.41 

 

Pro ověření přesnosti navržených automatických metodik stanovení průměru vláken bylo 

provedeno i manuální měření průměrů, dosažené výsledky se shodovaly s výsledky získanými 

v prostředí programu MATLAB i programu ImageJ. Na základě tohoto zjištění lze 

k vyhodnocení průměrů vláken doporučit algoritmus navržený v programu MATLAB nebo 

uživatelsky lépe aplikovatelnou metodu vytvořenou v prostředí programu ImageJ.  

 

5. Závěr 

Cílem příspěvku bylo představení objektivních algoritmů navržených v prostředí programu 

MATLAB a posloupných kroků vytvořených v prostředí programu ImageJ, vedoucích 

k určení kvantitativních charakteristik PCL nanovlákenných struktur lišících se koncentrací. 

Mezi charakteristiky, které lze na základě uvedených metodik spolehlivě identifikovat patří 

stanovení parametrů nanovlákenných pórů a kulovitých defektů vyskytujících 

se v nanovlákenných vrstvách, dále stanovení orientace a průměrů nanovláken. Všechny 

uvedené metodiky jsou efektivní, snadno interpretovatelné a lze jimi objektivně stanovit 

uvedené základní parametry nanovlákenných struktur. Přínos práce je mimo identifikaci 

parametrů nanovlákenných struktur i ve snadné interpretaci algoritmů navržených v prostředí 

programu MATLAB prostřednictvím uživatelsky lépe pochopitelného a přístupného programu 

ImageJ. Navržené posloupné kroky v prostředí programu ImageJ mohou být vhodnou 

předlohou pro stanovení datových informací z obrazu bez nutnosti tvorby složitých algoritmů, 

jako je tomu v prostředí programu MATLAB. Navržená posloupnost kroků vedoucích 

ke stanovení parametrů nanovlákenných struktur najde uplatnění nejen v oblasti nanovláken, 

ale i oblasti tkáňového inženýrství, kde může sloužit k identifikaci a popisu strukturních 

parametrů buněk nebo buněčných systémů.  
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